Seeing wrong interface in Inkbird Pro app for ISC-007BW

Hello

I have just purchased a smoker controller, ISC-007BW.

It has connected correctly and I have added it as a device I to the Inkbird Pro app. However I am seeing the wrong interface in the app.

I am not seeing the correct interface/information as per the manual. (I have a photo of the manual showing what I mean but cannot attach a second photo.)

Instead, I am seeing lots of Chinese characters and information that I cannot make sense of, as per the screenshot attached.

This means I can’t see or set the temperature via the app, or in fact perform any app functions for the device.

Anyone any ideas what to do?

Thanks

Hello,
May I know the phone model?
Is the Inkbird pro app the latest version? This problem may occur if it is an older version.
In addition, the ISC-007BW supports the INKBIRD app, which is an upgrade from the Inkbird pro app.
If the Inkbird pro app still has problems, maybe you could try the INKBIRD app?

Hi Tania

Thanks for your message.

It was the latest version. However I have now tried the INKBIRD app – this works in that I can now control the device and see the temperature, however I now have a new issue – the app won’t let me see the data chart and data history, it just says “No data”. I would be grateful if you could advise.

Thanks

image001.jpg

May I know if you are using WIFI or Bluetooth connection?
Please keep the ISC-007BW connected to the app.
Because it takes time to record data.
If you wait for a while, will it have the chart data?

Hi Tania

I am using wifi.

The device remains connected all the time.

I have tried it over a period of several hours, and even overnight, and it still says “No data”.

Please could you advise?

Thanks

Leigh

Could you please let me know the phone model and country? I will contact the engineers to check.
Thanks.

Hi
It is an iPhone 14. Country is UK.
Thanks

I contacted the engineers and they replied that they would fix this problem as soon as possible. They expect to update the app within the next few days.

Many thanks Tania – I have checked and this is indeed fixed now. Thank you!

1 Like