INT-11P-B not charging at all

I have an almost new INT-11P-B probe purchased directly from Inkbird.

I had no trouble setting it up and have used it a couple of times without issues.

I used it last night as follows:

Took the probe out of the charging case where it had been stored. The case was well charged with a solid green light.

I started the cooking cycle. After about 30 mins I noticed that the probe had gone offline. I couldn’t get it to reconnect despite bringing the phone and case near to the probe and trying several times. I then noticed that the probe battery was showing 0% despite being “connected”.

I removed the probe and cleaned it thoroughly and placed it back into the charging case. There was no “beep” after I put it in the case and after about 20 mins it was still showing as 0% but still “connected” to the bluetooth.

It is apparent that the probe is dead flat and not charging at all. I removed it from the case numerous times and tried to reposition it. It is around the correct way and properly ‘’clicked in”.

I removed the probe from the app and added it again - same result. Shows as connected but 0%. The case beeps when it is plugged into the USB cable and the solid green light shows Still no sign of any charging. Dead flat. Even tried overnight.

There is no dirt on the probe and the case contacts look perfectly clean.

Seems like the battery in the probe is gone? How dod I get a replacement?

Email Their support is decent, but a little slow to respond. They will have a new one sent out to you. Trust me, I’ve had multiples since November.

Yup! Mine are doing it too. I had just charged them ONE DAY AGO then after charge they both worked. This morning (6-10-2024) I went to use the one.the box linked up to phone but the sensor just said “disconnected”. I got out/in to the app, I pressed the button on the box for a good 20 seconds hoping that that would reset it. It didn’t. I put the sensor into the charging box and was pushing the top :top: up against the + contact and held it there for about 30 seconds. NOPE that didn’t work. I don’t know what I did but after sitting on table unable to use it for about 15 minutes I tried to connect again and it Worked. I didn’t do anything but somehow it working again.
I know that intermitting problems ARE THE hardest to solve but these are new, one is 2 weeks old and the other one is just one week old but they both have similar problems.
If this happens one more time (I use them everyday) their going back. In my situation I just can’t switch to another analog thermometer and still get that particular “job” done. It screws up everything when these fail. it’s VERY important to have WORKING TOOLS!

I will update on situation soon.
Dave C. Stout

If you encounter this problem again, please place the probe into the charging case, the charging case’s indicator light will light up for a few seconds. Then take the probes out, will they reconnect? If the indicator light of the charging case does not light up, please ensure that the probe direction is correct and adjust the position of the probe several times.
If that doesn’t work, please press and hold the button on the charging case for 30 seconds, and it will reset the device. Will they be able to connect after reset?
Please note that during reset, the probe needs to be placed in the charging case or next to the charging case.
Please press and hold the button of the charging case for 30 seconds. During this time, please do not let go even if the green light comes on. When you press and hold for a full 30 seconds, please release your hand, and its green indicator light will light up and then turn off.
Please wait for 15 seconds, the charging case may make a ‘beep’ sound and flash the green indicator several times then off.
Please check the status in the app, is the charging case and probe back connected?

Did U even read what I sent U !?
I did all that and thats why I wrote U.
I sent them back and I ordered another set.

Dave C. Stout

I apologize if this gave the impression that I hadn’t read your message carefully. Since the problem description did not mention the indicator light change (please understand that the indicator light can also be used to determine the product status), I repeated the details just to make sure nothing was missed.
The INT-11P-B has a one-year warranty. If the issue reoccurs and cannot be resolved, it can receive after-sales support via email at