IAM-T1 data loss

i just tried to download 1 days data and it failed. I had no problems downloading data previously. The inkbird screen was showing real time readings but when I tried to download, the IAM-T1 screen flashed and displayed the word INKBIRD like it restarted/reset. It now doesn’t have data from the morning prior to 9.50am. This was critical data as we’re monitoring air quality on bus trips for a company. Is there anything I can do to extract this data or has it been wiped?

Latest inkbird app 1.6.10. Motorola G51 5G with latest android 12 patch. Internet was unavailable when trying to download from the monitor.

May I ask if the bus is bumpy where the IAM-T1 is placed? We need to rule out whether the battery is loose due to the shaking of the bus, and causing the device to restart. Please understand that if the device is restarted, its data will be cleared.
Will the data after 9.50 be recorded? Is it possible to provide a video showing IAM-T1 screen flashed and displayed the word INKBIRD?
Please send the video to support@inkbird.com with a link to this post.

Hi Tania

Thanks for the reply. The screen flashed when it was on the dashboard
in a stationary car. It was showing a reading of 4200. I tried
connecting the app, the app crashed - showed failure to login because
internet wasn’t available and then the screen flashed on the Inkbird
and all data was lost. It was definitely not bumped at that time or
anytime in the last few minutes before the failure. Yes data was
recorded after 9.50 and has been fine since.

I can’t video this as it only happened one time. So data has been
completely wiped?

Sorry, if data is lost, it is unrecoverable.
Can we confirm that when the APP crashes, it occurs at:

  1. When clicking IAM-T1 to connect, the APP suddenly displays login failure and then crashes.
  2. When opening INKBIRD APP, login failure and crash occur.
    This can help us confirm whether it is a product problem or an APP problem so that we can make subsequent improvements.

Thanks for your cooperation.