Can't connect IBS TH3 to WiFi

Moved house and got a new router - now I can’t get the sensor to connect with the wifi (fails at pairing.)
I have looked at and tried all of the solutions offered in this thread:

  • Verified on 2.4 GHZ channel
  • Local network and wireless data enabled on iPhone
  • Wi-Fi security mode is WPA2-Personal
  • WPS is Off
  • Deleted old entry for the sensor in Inkbird app
  • Reinstalled Inkbird app
  • Left the batteries out of the unit overnight
  • Put new batteries in the sensor
  • Had phone and sensor in close proximity to the router
  • Powered phone on/off
  • Router does not have limited connections

I would love to have this working again.

Please refer to the router setup section of this post.

If you have two phones, could you please test:
Turn on the hotspot of phone A, it will work as a 2.4GHz wifi router. Phone A is placed next to the product.
Phone B connects to the hotspot of phone A, and downloads the INKBIRD APP.
Phone B connects to the product as instructed by the app.
If the product can connect to phone B in this test, it means its WIFI function is working. Please recheck the router settings.
This can help us check whether it is a router setting problem, or a device setting problem.

I will test this as soon as I can - may be the weekend.

I had the same issue.

When renaming the ssid to the prior ssid it would reconnect no problem. Buy I never got it to connect to the new one. It just won’t reset its data.

I moved from Zyxel to Asus.

I thought it was smart connect causing the issue so I tied the mac in asus UI, gave it an IP and all, assigning to 2.4 and it never wanted to connect.

I turned off 5ghz and smart connect and still never connected. Only upon renaming ssid to same ssid as prior router would it connect.

It’s as though when you reset it it doesn’t update its wifi data.

Inkbird sent me a new one and all’s well.

I have now tested this - unfortunately the inkbird still fails to pair.

Sorry about that.
Please email with your order information and link to this post for after-sales services.

Thank you for your assistance.

I bought two TH3, I put new batteries in both and pressed the side button for 8 seconds… The light never appeared to begin pairing… Checked the batteries several time. no luck. Returning them and purchased TH3 from another reseller… is there a faulty batch?

May I know are you using non-rechargeable alkaline batteries?
If the indicator light is checked in a dark environment, will it not light up?
Please understand that in order to save power, the brightness of the indicator light of IBS-TH3 is relatively weak. Please do not view it in a brightly lit place, otherwise it may be unclear.

I have had the same experience, I carried out all the usual checks, 2.4ghz etc but still wouldn’t connect. I then tried in a friend’s house and it still wouldn’t connect to WiFi. I should have returned it via Amazon but I chucked it in the drawer because it has wasted too much of my time already. I will not buy any more Inkbird products.

Sorry to hear that.
IBS-TH3 comes with a 1-year warranty.
If you have any problems with the product during use, please feel free to contact via email for after-sales service.

I had a similar problem. I have had 3 existing TH-3s that have been working for over a year with no problems. I recently purchased three more. Sometimes these new ones would connect but would stay online for no more than a few hours. Eventually they would not connect at all. I downloaded the app on my wifes older Iphone (12) and all the new ones connected and stayed online. Aso my three older TH-3s showed up on her phone. I then deleted the app from my Iphone (14) and reinstalled the app. Everything is good and all are working without problems. It was frustrating and I was ready to send the new ones back. I don’t know what caused the problem but hopefully this will help someone.