IBS-M1 no Connection

I have an IBS-M1 and I can not connect it to the app. I get the message in both fast and slow mode: Device not responding.

How can I connect the device?

With kind regards


IBS-M1 supports Inkbird pro app and INKBIRD app, may I know which app are you using? Maybe you can try changing the app?
Please check if the settings of your phone and router are correct.

I use the Inkbird pro app (but have also tried the Inkbird app). Same error with both. I have only 2.4 Ghz wifi enabled and the smartphone, the IBS-M1 and the router are next to each other. I have already reinstalled both apps. When connecting (whether fast or slow) the wifi icon flashes until 7% is reached, then it goes out and lights up permanently from about 16%. When 100% is reached, the message “Device not responding” appears.

Could you please let me know the phone model?
If the WIFI icon lights up permanently, it means that it is connected to the app. If you scroll down and refresh on the home page of the app, does it show the IBS-M1?
If possible, could you test with another phone in order to rule out if it is a phone setting issue?

it is a Huawei P30 pro. I tried it with a second P30 pro, same result. Unfortunately, I have no other device at hand at the moment. An update in the app brought unfortunately no remedy. The IBS-M1 shows up with an IP address in the router, just not in the app.

I contacted the engineers and they tested but found no problems. Is it possible to provide your order information, mobile phone (Huawei P30 pro) system, app account (email), and a video of how you paired the IBS-M1 to support@inkbird.com? This could help the engineers to do further analysis.
Thanks for your cooperation in advance.