Can't connect IBS-TH3 to WiFi

Changed my wi-fi SSID and can’t get my IBS-TH3-WIFI to connect again. It was connected before so not sure what the problem is.

I get the blue blinking light on the sensor and the phone can find it but it can’t connect it to the wi-fi.

Here’s what I tried already

  • Verified on 2.4 GHZ channel
  • Local network and wireless data enabled on iPhone
  • Wi-Fi security mode is WPA2-Personal
  • WPS is Off
  • Deleted old entry for the sensor in Inkbird app
  • Put new batteries in the sensor
  • Powered phone on/off
  • I was able to reconnect my ITC-308 Thermostat to wi-fi with no problems

Not sure what else to try. Anyone have ideas?

Please refer to the router settings:

Please ensure that the router does not have a limit on the number of devices that can be connected.
When connecting, please ensure that the WIFI name and password entered are correct, it has no extra characters or spaces.
If you remove the batteries from the IBS-TH3 and wait for 30 minutes before installing it, will it work?

I have an Asus ZenWiFi AX router that does not have a limit on devices.
I have double checked and retyped the wifi password. It is correct.
I removed the batteries for 2 hours.

It still does not work.

My ICT-308 connects to wifi fine. What is the difference between these two inkbird devices?

Just a test in order to rule out that the WIFI setting is the cause. Will the IBS-TH3 connect if the WIFI SSID is changed back to the original?

I have the same issue. Connected it to a WiFi network and after changing SSID cannot connect to this or any other WiFi. Changed the SSID back as Tania suggested below and IBS-TH3 connects immediately. So, how to reset the unit to make it connect to another WiFi?

May I know if you have deleted the IBS-TH3 from the app and reconnected it after changing the SSID?
Because IBS-TH3 will not recognise the changed WIFI settings. If you have changed the WIFI settings, please disconnect the IBS-TH3, enter the new WIFI name and password into the app and reconnect IBS-TH3 to the app.
If the SSID has been changed, you will not be able to reconnect after disconnecting the IBS-TH3, but changing it back to the original SSID will work. Please provide your phone model, original SSID and changed SSID, WIFI password (if it has changed) to .
I will contact the relevant colleagues to test this with the same settings.

If I change the SSID back to the old one the IBS-TH3 reconnects. However I’m not able to keep using the old SSID so I need to be able to connect to the new SSID.

I have emailed the information you requested to

1 Like

I am having same issue with IBS th3 and IHC 200

Just received a new IBS-TH3 and have tried around 50 times to connect to my Wi-Fi without success using iOS app.

Triple checked that my router settings are as stated, turned off 5GHz so all my devices are on 2.4GHz, WPA2 etc, etc and still can’t connect.

Is this something to do with, maybe, when I get to the Wi-Fi selection and click the arrow to go to select the Wi-Fi, nothing happens apart from going into the iOS settings of the Wi-Fi connection I selected. I then have to go back in to the Inkbird app and enter the password but the Wi-Fi address isn’t visible above the password because iOS won’t let it be selected. This is an Inkbird app issue I think.

Also, how do I know of the blink mode is slow or not because I can’t find a way of changing the blink speed.

I think I’ve just resolved this.

I downloaded the app on my iPad and when I got to the select Wifi in the setup it automatically entered my Wi-Fi name and I’ve now managed to add the device to my network.

Looks like it is an issue with the iOS Phone app that doesn’t let you select or type the Wi-Fi name in or auto complete it like it did on the iPad.

I also plugged in my old router and old ssid and it connected right away.

I got a new ib3th3 and it connected to my new router no problem.

It seems the issue is, holding down the button on the IBSTH3 doesn’t reset the wifi, and despite selecting a new ssid and entering password, the phone doesn’t send it to the IBSTH3 that had the old ssid.

Please try:

  1. delete the IBS-TH3 in the INKBIRD app
  2. remove the batteries of the IBS-TH3
  3. change the SSID to the new one
  4. install the batteries of IBS-TH3
  5. connect the IBS-TH3 to the new SSID

Please follow the order of the steps. Can it work?

Already did…

Doesn’t do anything.

Please email with order information and the link of this post, my colleagues will provide after-sales service.