Problems with inkbird iic-600-wifi

Inkbird iic-600-wifi is apparently working properly but when starts to operate both automatically and manually the session of each water line lasts seconds. I’m not able to configure to last for minutes even if apparently it has to last for 15 minutes.

Please check the power of the water valve, is it in the 24VAC, 1A range?
Please check that is it wired correctly?

Hi Tania,

thank you for your kindness.

I replaced all the water valves and now the app is working fine regarding the duration of each session.

Now I have a new issue.

Some valves remain always open, regardless the planning schedule or the manual use of them…

Do you know if there is some other setup to be adopted?


Thank you in advance!

Kind regards, Alfonso

Just to confirm, is the power of the water valve in range? Is it wired correctly?
Please understand that if the water valve is the wrong power or is wired incorrectly, it is possible to cause this problem.
If all is correct, is it possible to provide which zone is having the problem, and a video of the problem to email

I have this same original issue. It turns on for about 10 seconds on manual or on a program and then turns off. It won’t complete the program. I am using 24VAC Hunter solenoids and they have been working with my previous sprinkler controller for 10 years with no issues. I have two wires running from two boxes with solenoids and valves. One box has three solenoids and all three of those zones work correctly. The second box has two solenoids and neither of them will complete a program. I can start the program, but it fails after about 10 seconds and turns off. Any advice? I’ve tried moving the common connection from the C port on the right to the C port on the left, sharing it with the other zone. No change. I’ve checked both boxes and all wires are connected with sealed connections. Thanks in advance. The only difference is that one zone has three solenoids and the other has two. There is no Master Valve connection.

Please make sure the wires are not loose or broken.
Please check if the wiring is correct. The water valve will have 2 wires, one of which needs to be connected to port C and the other to a different number. For example, the 1st water valve is connected to Port C and #1, the 2nd water valve is connected to Port C and #2, the 3rd water valve is connected to Port C and #3… and so on.

The wiring appears to be correct. I’ve ordered some new solenoids as I noticed the two that aren’t working properly have a red and a black wire, while the three that work have two red wires, so perhaps there is an issue with the model with the red and black wires. All five worked fine with the previous Hunter controller.

Thanks for your information.
Please understand that the water valve specifications supported by different controllers may be different.
Just in case, please make sure that the power of the newly purchased water valve is 24VAC, 1A.

I replaced the solenoids with what look to be the same as the ones that worked before and everything works. I also had to update the app again to get it to connect properly and to respond properly when I tried controlling zones manually, but now it appears to be stable.

1 Like