IBBQ-4T will not connect to Wi-Fi, can't change to Fahrenheit

I have not been able to connect the my IBBQ-4T to my network. I have tried connecting it to my 2.4GHz channel. I sat my phone and the Thermometer right next to the router. Still no luck. I keep getting a message that it can’t find a device. I have tried the fast flash method, and the slow flash method. My phone can see the smart device network, but it still does not connect to it. I really wouldn’t care if I could change the setting from Celsius to Fahrenheit. I can’t do that because I can’t connect it to the network and there is only one button on the machine. It has become frustrating.

Are you using the latest version of the INKBIRD app?
Please check if the router is set up correctly?

As stated above. I have the thermometer and my phone sitting right next to the router. Yes, I am using the latest version of the app. I am using the 2.4 GHz band. I am still unable to connect to the thermometer. I really just need to change it to Fahrenheit. It seems ridiculous that I can’t do this without connecting to a network. I am very disappointed with the product. Please read the reviews for the app on the Google Play store. It currently has 1.9 stars.

Please understand that the settings of the router itself and the phone settings will also affect the connection of the device. If the settings are wrong, they will not pair even if the 2.4GHz wifi is connected and the device is placed next to the router.

Please check that the settings on the router are:
Wireless protocol: 802.11 b/g/n, but cannot be set to 11n only.
Security mode: WPA/WPA2
Authentication type: AES
There is no limit to the number of connected devices on the router.
If possible, please use the slow flash mode.

Please check the phone settings - INKBIRD APP, do you agree to all the permissions for INKBIRD APP? Is the Bluetooth and location function of the phone turned on?