App not working. Cannot login

I have the most current inkbird app. since the update the notifications have stoped coming though. I tried uninstalling the app and re-installing. Now i cannot even login. Ive tried on 3 devices and tried registering a new account with no luck.
anyone else with a similar issue. its rendered my items useless without the app.

1 Like

I am having the same issue. I cannot login, register an account, or change password. It worked great before the update or whatever they did. Placed a 1 star review in the app store.

1 Like

Same problem for me!

I tried again this morning and it finally let me re-register. It’s now working as intended. Hopefully its resolved all around.

Thanks , I tried 15 mins ago and still not working for me.
Do you need to re-register?

Same here. I’ve been trying for days and can’t get it to work. There are precious few messages to let me know what I need to do. Some I don’t understand. For example, what does “register directly” mean? Even worse, there’s no support on weekends. So, I don’t know what to do, other than to wait till support is available.

1 Like

Sorry for the inconvenience caused by unexpected problems with the APP. Engineers have urgently repaired the problem within 24 hours. If you have any questions, please feel free to contact support@inkbird.com via email.

Seems not to be fixed. Same problem for me I cannot login in the app. After accepting the privacy statement nothing happens. Register a new account also does not work.

1 Like

Same problem for me… i can’t login, change password or register.
I can’t use my Inkbird ISC-027BW now since it depends on the APP.

fix this issue please.

1 Like

Mine is not working either, I am PO ed. Now I have to go outside on christmas eve, because the app isnt working. For a 9 hour smoke.
If this isnt fixed by the next time I use it I will give very bad reviews!
I have the bbq 4T AND IT WASNT CHEAP EITHER!

I’ve sended an email and got a reply back that they urgently fixed it and to try again. I can login now and the app is working again.

I’m a new user and facing same problem. Unable to register through app. Get some message about it timing out. Tried registering through this website as well and using that username/password but it just spins forever with no error message.

Why the fuck does an issue with this login service prevent me from seeing the temperature of my own local device? Trash design with unreliable service. And now I’ll have to deal with the hassle of returning the device for a refund.

Me too. I have been using the app for several years. I have a new phone now so I installed the new app. I can’t log in to my account on my new phone at all. Nor can I login to my account on the web, I just created a new account to do this rant.
My old phone remains connected so I can see my devices but you can understand how this might be really very very annoying.

Old phone: android
new phone: android
ipad also fails with the latest app

Please fix all the apps, or servers, or whatever else is broken!

I forgot to add that attempting to login or reset my password results in a “user not registered” message

I just bought some product that I cannot install and use because the apps won’t login: it keep saying that I am not a registered user although I did create an account (and can connect on the web site fine)

1 Like

I was having the same problem. Deleted the app. Reinstalled it. Was able to log in. Terrible app wow.

Same problem for me going on like 6 months…