ITC308WiFi cant connect to my phone app

I purchased this last year to control two small pipe heaters to keep my solar batteries warm between 15 and 18 degrees C, all OK.
Last week I fitted a mesh broadband so the battery store is now reached by broadband.
So this week I tried to connect my Ink Bird to the App.
Broadband ok, Broadband password ok, tried to connect x6, checked everything, but it just wont connect. Solutions please?
Thank you Max

Please refer to this post and check whether the router settings are correct?
Please use slow flash mode to connect.
Can it work?

Tank you for the response, I am sorry but I don’t know what the following actually means?
“Please use slow flash mode to connect.”

Yes the Virgin broadband transmits at 2.4ghz and it links to my 2.4ghz inverter perfectly.
As well as the new fibre Virgin router I have an Eero mesh of three units so I have a strong signal everywhere. Initially the Inkbird was next to an eero mesh unit and I was not able to make the wifi on the inkbird work, so I brought the inkbird inside my house and it was next to the Virgin router and still it wouldn’t work.
My mobile phone in both location had a maximum strength signal from my eero mesh.

Yes this week I downloaded the inkbird app from playstore.
Yes Bluetooth was switched ON.

I use an android mobile phone.

So I set the inkbird up using the idiot sheet that you publish, but no wifi solution.
What do I do now?
Regards Max

I offer the following for you and Inkbird to consider. You may be experiencing - Band steering means the modem will also only appear to have one Wi-Fi network, despite offering both 2.4GHz and 5GHz bands. This can cause some older or niche devices to have connectivity issues. The Inkbird did not seem to relate to the Band negotiation.
I had to create a Guest network 2.4GHz only.
Connected without a problem.
I will be interested in Inkbird’s comments.

I had a recent problem getting my app to connect. In the end, I removed the app entirely and reinstalled it and was then able to connect.