IPT-2CH add device problems

I’m in an apartment with a hybrid 2.4/5-GHz Wi-FI network. I know that the IPT-2CH only works on 2.4-GHz but there is no way to force my iPhone onto the 2.4-GHz nor, to what I’ve been able to see, a way to know which network the phone is connected to. When I try to add a device in SmartConf Mode, I get messages on the app saying “Device found” “Register Device to Smart Cloud” and “Initializing device . . .” Given that the Device was found, I would think that the iPhone and IPT-2CH have to be on the same network, but after going through the 99% circularly timing screen, I get “Device not responding.” When I try using AP Mode, I see and am able to connect my iPhone to the SmartLife-8089 router, so again I’m thinking they have to be on the same network to do this. But then I keep getting “Server error, please try again later.” The IPT-2CH, iPhone and router are all within 3 feet of each other and I have multiple IPT-2CH devices which are all doing the same thing. Any suggestions are appreciated.

Please understand that when the device is connected for the first time, the mobile phone and IPT-2CH need to be on the same 2.4GHz wifi network.
If the IPT-2CH is successfully connected to the INKBIRD app, the phone can be switched to other networks.
If the phone is using a hybrid 2.4/5-GHz Wi-FI network, this may cause the phone to automatically switch to 5GHz wifi during the connection process, which will cause the connection to fail.
Because the signal range of 2.4GHz wifi will be farther than that of 5GHz wifi. If the router’s network cannot be separated, maybe you can try placing the IPT-2CH next to the router, but place the phone a little further away, will they be able to connect?
Besides, please make sure your router and phone are set up correctly.


I now have the IPT-2CH connected to my iPhone and programmed. But still have a couple of problems:

  1. Per the picture attached, I keep having errors in what the app is telling me. The picture shows that both the IPT-2CH units controlling the right and left side heat pads as well as the IPT-2CH controlling the heat lamps are all online. However the app suggests that the unit controlling the heat pads on the left side is having a “Probe abnormality.” When I click through on that device, I get “Probe is not inserted” on both sides. But the probes ARE inserted and the controller is showing the temperature of each probe. The really weird thing is that this is happening on and off on the app for each of the controllers.

  2. The IPT-2CH controlling the heat lamps is set for turning on at 75 degrees F and off at 78 degrees. When the temperature drops below 75 (as you can see in the picture, one is at 74.6 degrees) the heat lamp should turn on. The display on the controller does show W2 on, but the heat lamp does not warm up. I have tried new heat lamps and bulbs and that doesn’t improve the situation. The bulbs are each rated for 150W, so the 300W total is below the 500W rating of the controller so these should work.

Any suggestions for resolving these issues would be appreciated.


Please check if the probe plug is fully inserted into the port? Please make sure they have no gaps.
Please make sure you are using the latest version of the INKBIRD app.
If it is still having problems, due to privacy concerns, please provide the link to this post, order information, and the device ID of the IPT-2CH to email support@inkbird.com.
This helps engineers further examine the problem.