IHC-200-WIFI stopped displaying on app

3 week old IHC-200-WIFI was working fine but stopped providing a reading on app while still showing online. When clicking it now reads what looks like diagnostic information in Chinese. The device itself is working but not on the app, all other inkbird devices are reading fine on the app. Tried power cycling, a factory reset and re-adding it to the app with same results.
Is this is a known error or has the device gone faulty?

If you are using the Inkbird pro app or Inkbird smart app, please download the INKBIRD app. Please connect the IHC-200-WIFI to the INKBIRD app.
Can it work?

It works on the inkbird app, however it does not have a tile display where I can see the status of multiple devices without clicking into them. It is not useful for my needs as I have 5 other inkbird devices, I would like to understand why it stopped working on inkbird pro and is now giving the output shown, is there a device limit or can it be fixed if I get a replacement? Thanks

This problem may occur because Inkbird pro is not compatible with new batches. Please click on more in the top right corner, please provide the device ID and I will consult the engineers if it can be adjusted.
Regarding the homepage of INKBIRD app can’t display the reading of the devices, the engineers have now put it on the schedule and they will update it as soon as possible.

I don’t understand this, why would it not be compatible if it worked fine for a week? I’m considering returning this device at this stage as no explanation makes sense other than the device suddenly going faulty. It’s id - bf39b46cce8e90a0zdlt

The engineers will fix this issue in the Inkbird pro app.
Please check if the device ID is correct? Sorry they can’t search for devices by this ID.
Maybe you could provide a screenshot of the device ID?
Besides, please make sure that the Inkbird pro app is the latest version.
Thanks for your cooperation in advance.