Connecting ITC-308-wifi with firewall

I just got a new ITC-308, downloaded the inkbirdsmart app to my iphone, and tried to connect the app to the device. No luck. On the app, I get the device to rapid blink mode, type in the 2.4 GHz network and password, have it attempt to connect, no luck. I never see the anything connected to the 2.4 GHz network on my Netgear router. On my firewall, I see a udp traffic on port 30011 from my iphone to broadcast ( and udp traffic on 30012 from my iphone to multicase ( – I have adjusted my firewall rules to allow for this.

Any ideas what is failing here? I moved my iphone from the 5 GHz to 2.4 GHz wireless network (it shows up on the router), to see if that helped. Nope. A technical description of what happens during connection would help me.

Please download and use the INKBIRD app instead of the Inkbird smart app.
For the troubleshooting, please refer to this post:

Ok, I changed the iphone app to the basic inkbird app and tried again. It still does not work either in fast flash or AP mode. With my firewall, I see the burst of UDP traffic to broadcast and multicast on port 30011 and 30012, followed by rejected outbound tcp 443 traffic to networks in China ( Guangzhou NetEase Computer System and Guangzhou Wangyi Computer Systems). I firewall reject all traffic to/from China and Russia, period.

A technical description of the network traffic and some error messages would help, eg “could not connect to network”, “could not find device”, "could not establish contact with… ".

I contacted the engineers and they replied that if the router is set up with this kind of firewall, it will block the connection of the device.
If possible, please use a router without a firewall or special network settings.

Sorry, that won’t happen. China stays blocked on my firewall.