i have a nighthawk router with both

5g and 2.4 g

when both wifi or ap setting neither will connect

i try to enter the 2.4 g network name and password its all correct
and will not connect


1 Like

Please refer to this post:

thank you for this info i apreciate it

after changing wifi setting on 2.4 g to wpa/wpa2 and puting exact acuate location and always on for the app . i tried with ap and slow blink exactly as stated . the blink stops at 14% on connection adn by 40% it shows a constant red lick at the wifi symbol. by 100% it says not responding check wifi passwords and all that stuff. when i exit the error messege the botton is a grey bar

saying ( connecting) ?

also i used inkbird smart app and inkbird pro both are saying timed out or not responding not sure why this is

Please note that before pairing, the phone is connected to 2.4GHz wifi, please make sure that it does not automatically switch to 5GHz wifi during the connection.
Please check whether the permissions of the app are enabled in the mobile phone settings, and whether the location function of the mobile phone is turned on? If possible, please use another mobile phone to test the connection to rule out whether it is a mobile phone problem?
When entering the WIFI password, please make sure it has no extra spaces.

If it still doesn’t work, please check if the wifi module is working well (It is for detecting if there is a problem with the wifi module, it is not for wifi connection.):
Please change the hotspot name to tuya_mdev_test in the mobile phone hotspot first (Crucial step), then turn on the hotspot, and put the mobile phone close to ITC-308 WIFI. Here are the test steps:

  1. Please unplug the ITC-308 WIFI (turn off the power);
  2. Press the ‘set’ button;
  3. Please do not release the ‘set’ button until power on, it will enter test mode;
  4. Press the “Down” button, ITC-308 WIFI will display the communication signal, wait for a few seconds;
    What does PV and SV show?

ok just a min let me try

did everything u mentioned and the set button held for over 2 minutes never turned on while unplugged

does not change or switch to 5 g on my phone while trying the connection

i think it may just be the router i am using so i will buy a new one for this unit just a 2.4 g

For what its worth have you tried disabling 5ghz (switch it off). I have same issue with other control equipment like Sonoff stuff, and switching off 5ghz works. Then of course when connected switching it back on.

My router does not give out enough signal strength (maybe faulty). So I have a Tp-link EAP110 sitting right next door to the router, and everything connects to that. Perfect.

not sure how have spectrum internet box with nighthawk router on the nighthawk app it wont let me disable it by itself and i cant find a way how

Hello, I am having the same issue. I have a spectrum router that operates on both 5 & 2.4
Light is fast blinking but I cannot get it to connect. Devices are practically touching each other as well.
I put the 308 controller into test mode and

1 Like

May I know which app you are using?
Are the 5 & 2.4 wifi signals of the router separate?
If you want to test the signal, please make sure that the phone is placed next to ITC-308-WIFI, the hotspot is turned on on the phone, and it is named tuya_mdev_test. Otherwise, this test is invalid.

I am using the Inkbird pro. Hotspot on my phone is turned on.
Router shows both signals when I test my internet connection.
Did not rename for the test tho.

Please use the INKBIRD app, which is an upgrade based on the Inkbird pro app.
Please make sure your router is set up correctly, please refer to the previous troubleshooting post, please use the slow flash mode connection.
Can it work?

I had the same problem. I put the 308 controller into test mode and
Then I downloaded Inkbird pro app. Works ok now.